Listen tcp 0.0.0.0:53: bind: address already in use

I am trying to setup Auto DNS but when I change HOST_PORT_BIND to 53 in my .env file, I can no longer start Devilbox without the following error:

$ docker-compose up httpd
Creating devilbox_bind_1 ... error

ERROR: for devilbox_bind_1  Cannot start service bind: driver failed programming external connectivity on endpoint devilbox_bind_1 
(28eee4fad723afd8f4d584c935897ee9eb85d53efaffe7043278f024dc2711b8): Error starting userland proxy: listen tcp 0.0.0.0:53: bind: address already in use

ERROR: for bind  Cannot start service bind: driver failed programming external connectivity on endpoint devilbox_bind_1 
(28eee4fad723afd8f4d584c935897ee9eb85d53efaffe7043278f024dc2711b8): Error starting userland proxy: listen tcp 0.0.0.0:53: bind: address already in use

When I change port 53 back to 1053, Devilbox works fine. I’m on Pop!_Os (Ubuntu) and am not experienced with network settings but I searched around on Google and found that I should look at what program might be listening on port 53. So I enter this command in terminal:

sudo fuser -v 53/tcp

And it shows:

53/tcp:              systemd-resolve    874 F.... systemd-resolve

Frankly, I don’t know how this helps. I could really use some suggestions on how to troubleshoot this further please?

Did you ever find out how to fix this? I’m using WSL and there is nothing running on port 53; the command above returns empty.

This tells you that another program is already listening on that port. Therefore the Devilbox DNS server is unable to bind to that port and does not start.

To mitigate this, you will need to ensure that on your local machine no other service is listening on port 53