AutoDNS: Windows 10 + Docker Toolbox + ipv6?

Hi i have some problem with dns resolution in windows 10. Im using ipv6. Dns6 servers takes higher priority in name resolution.
So if I added ipv4 address of my docker machine to the network interface on my host as dns4 service, the name resolution not working.

nslookup returns non existent domain, from dns6 service :frowning:

if i disable ipv6 on my hosts network interface,

nslookup returns, from dns4 service (docker machine - devilbox).

How to change priority for dns name resolution in Windows ? (first ipv4 then ipv6 )

I do it my way :smiley:
I installed Deadwood a recursive DNS cache service to my host Windows system.
And now Autodns working fine for me.