Permission denied

I’m using devilbox on Mac OS X Catalina. I have installed docker desktop version and Compose 1.25.4.

I maintain a typo3 website, which is hosted at a provider. Now I want to make an upgrade from Typo3 8.x to 9.x and want to install and test this with devilbox.

I installed devilbox in the latest version and copied my typo3 installation from the provider to the devilbox data directory per ssh.

In the .env file I selected mysql 5.7, nginx-stable and php 7.3. The import of my mysql database seems to be ok.

Now if I start docker-compose.yml I get the following error in the browser:
Warning : require(typo3_src-9.5.13/index.php): failed to open stream: Permission denied in /shared/httpd/tsv-niederviehbach/htdocs/index.php on line 22

Fatal error : require(): Failed opening required ‘typo3_src-9.5.13/index.php’ (include_path=’.:/usr/local/lib/php’) in /shared/httpd/tsv-niederviehbach/htdocs/index.php on line 22

If I log in to devilbox with the script and want to go the directory “typo3_src-9.5.13” I got the same error:
bash: cd: typo3_src-9.5.13/: Permission denied

I got the same error, if I want to go to other directories in the data folder.

The directory has the following permissions:
drw-r–r-- 11 devilbox devilbox 352 Feb 23 15:03 typo3_src-9.5.13/

Does anyone have any suggestions, what I’m doing wrong?

The directory is missing the x the executable bit. It has wrong permission. Do a chmod 0755 /path/to/dir